Polecenia sprawdzające status routera

Z SOISK systemy operacyjne i sieci komputerowe
Przejdź do nawigacji Przejdź do wyszukiwania

Sprawdzany rożnymi poleceniami show będzie ruter widoczny na rysunku

Packettracer3.jpg

show version

Wyświetla konfigurację sprzętową, wersję oprogramowania, nazwy plików konfiguracyjnych, obrazy procedur startowych, przyczynę ostatniego restartu.

Router>ena
Router#show version
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang
Image text-base: 0x8000808C, data-base: 0x80A1FECC

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Copyright (c) 2000 by cisco Systems, Inc.
ROM: PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)

System returned to ROM by reload
System image file is "flash:pt1000-i-mz.122-28.bin"

PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory
.
Processor board ID PT0123 (0123)
PT2005 processor: part number 0, mask 01
Bridging software.
X.25 software, Version 3.0.0.
4 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
63488K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

show processes

Lista aktywnych procesów

Router#show processes
CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%
 PID QTy       PC Runtime (ms)    Invoked  uSecs     Stacks TTY Process
   1 Csp 602F3AF0            0       1627       0 2600/3000   0 Load Meter 
   2 Lwe 60C5BE00            4        136      29 5572/6000   0 CEF Scanner 
   3 Lst 602D90F8         1676        837    2002 5740/6000   0 Check heaps 
   4 Cwe 602D08F8            0          1       0 5568/6000   0 Chunk Manager 
   5 Cwe 602DF0E8            0          1       0 5592/6000   0 Pool Manager 
   6 Mst 60251E38            0          2       0 5560/6000   0 Timers 
   7 Mwe 600D4940            0          2       0 5568/6000   0 Serial Backgrou
   8 Mwe 6034B718            0          1       0 2584/3000   0 OIR Handler 
   9 Mwe 603FA3C8            0          1       0 5612/6000   0 IPC Zone Manage
  10 Mwe 603FA1A0            0       8124       0 5488/6000   0 IPC Periodic Ti
  11 Mwe 603FA220            0          9       0 4884/6000   0 IPC Seat Manage
  12 Lwe 60406818          124       2003      61 5300/6000   0 ARP Input
  13 Mwe 60581638            0          1       0 5760/6000   0 HC Counter Time
  14 Mwe 605E3D00            0          2       0 5564/6000   0 DDR Timers
  15 Msp 80164A38            0      79543       0 5608/6000   0 GraphIt
  16 Mwe 802DB0FC            0          2       011576/12000  0 Dialer event
  17 Cwe 801E74BC            0          1       0 5808/6000   0 Critical Bkgnd
  18 Mwe 80194D20            4       9549       010428/12000  0 Net Background
  19 Lwe 8011E9CC            0         20       011096/12000  0 Logger
  20 Mwe 80140160            8      79539       0 5108/6000   0 TTY Background
  21 Msp 80194114            0      95409       0 8680/9000   0 Per-Second Job
  22 Mwe 8047E960            0          2       0 5544/6000   0 dot1x
  23 Mwe 80222C8C            4          2    2000 5360/6000   0 DHCPD Receive
  24 Mwe 800844A0            0          1       0 5796/6000   0 HTTP Timer
  25 Mwe 80099378            0          1       0 5612/6000   0 RARP Input
  26 Mst 8022F178            0          1       011796/12000  0 TCP Timer
  27 Lwe 802344C8            0          1       011804/12000  0 TCP Protocols
  28 Hwe 802870E8            0          1       0 5784/6000   0 Socket Timers
  29 Mwe 80426048           64          3   21333 4488/6000   0 L2MM
  30 Mwe 80420010            4          1    4000 5592/6000   0 MRD
  31 Mwe 8041E570            0          1       0 5584/6000   0 IGMPSN
  32 Hwe 80429B40            0          1       0 2604/3000   0 IGMP Snooping P
  33 Mwe 804F43B0            0          5       0 5472/6000   0 Cluster L2
  34 Mwe 804F18D0            0         17       0 5520/6000   0 Cluster RARP
  35 Mwe 804EA650            0         23       0 5440/6000   0 Cluster Base
  36 Lwe 802A1158            4          1    4000 5592/6000   0 Router Autoconf
  37 Mwe 80022058            0          1       0 5624/6000   0 Syslog Traps
  38 Mwe 8031CE88            0          1       0 5788/6000   0 AggMgr Process
  39 Mwe 8035EF88            0        407       0 5592/6000   0 PM Callback
  40 Mwe 80437B58            0          3       0 5556/6000   0 VTP Trap Proces
  41 Mwe 80027D40            0          2       0 5676/6000   0 DHCPD Timer
  42 Mwe 8040D3B0            0          2       0 2560/3000   0 STP STACK TOPOL
  43 Hwe 8040E338            0          2       0 2560/3000   0 STP FAST TRANSI

show protocols

Wyświetla skonfigurowane protokoły

Router#show protocols
Global values:
  Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
  Internet address is 10.0.0.1/8
FastEthernet1/0 is administratively down, line protocol is down
Serial2/0 is up, line protocol is up
  Internet address is 172.16.1.1/16
Serial3/0 is administratively down, line protocol is down
FastEthernet4/0 is administratively down, line protocol is down
FastEthernet5/0 is administratively down, line protocol is down

show flash

Informacje o pamięci

Router#show flash

System flash directory:
File  Length   Name/status
  3   5571584  pt1000-i-mz.122-28.bin
  2   28282    sigdef-category.xml
  1   227537   sigdef-default.xml
[5827403 bytes used, 58188981 available, 64016384 total]
63488K bytes of processor board System flash (Read/Write)

show cdp neighbors

Informacje o sąsiadach CDP

Router#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Switch       Fas 0/0          125            S       PT3000      Fas 0/1
Router       Ser 2/0          131            R       PT1000      Ser 2/0

show cdp neighbors detail

Jak wyżej tylko w szczegółach

Router#show cdp neighbors detail

Device ID: Switch
Entry address(es): 
Platform: cisco PT3000, Capabilities: Switch
Interface: FastEthernet0/0, Port ID (outgoing port): FastEthernet0/1
Holdtime: 146

Version :
Cisco Internetwork Operating System Software
IOS (tm) PT3000 Software (PT3000-I6Q4L2-M), Version 12.1(22)EA4, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2006 by cisco Systems, Inc.
Compiled Fri 12-May-06 17:19 by pt_team

advertisement version: 2
Duplex: full
---------------------------

Device ID: Router
Entry address(es): 
  IP address : 172.16.1.2
Platform: cisco PT1000, Capabilities: Router
Interface: Serial2/0, Port ID (outgoing port): Serial2/0
Holdtime: 152

Version :
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang

advertisement version: 2
Duplex: full

show interfaces

Informacja o interfejsach rutera

Router#show interfaces
FastEthernet0/0 is up, line protocol is up (connected)
  Hardware is Lance, address is 0002.4ac7.8407 (bia 0002.4ac7.8407)
  Internet address is 10.0.0.1/8
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00, 
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 19 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     111 packets output, 7972 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet1/0 is administratively down, line protocol is down (disabled)
  Hardware is Lance, address is 00d0.9734.ebc9 (bia 00d0.9734.ebc9)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00, 
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Serial2/0 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 172.16.1.1/16
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 96 kilobits/sec
  5 minute input rate 15 bits/sec, 0 packets/sec
  5 minute output rate 13 bits/sec, 0 packets/sec
     112 packets input, 5824 bytes, 0 no buffer
     Received 112 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     112 packets output, 5824 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
Serial3/0 is administratively down, line protocol is down (disabled)
  Hardware is HD64570
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 96 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=down  DSR=down  DTR=down  RTS=down  CTS=down
FastEthernet4/0 is administratively down, line protocol is down (disabled)
  Hardware is Lance, address is 0090.0c4d.3b26 (bia 0090.0c4d.3b26)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00, 
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet5/0 is administratively down, line protocol is down (disabled)
  Hardware is Lance, address is 00d0.ba63.db32 (bia 00d0.ba63.db32)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00, 
  Last input 00:00:08, output 00:00:05, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

show startup-config

Wyświetla konfigurację startową rutera

show running-config

Wyświetla aktualną konfigurację rutera

Router#show running-config
Building configuration...

Current configuration : 689 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.16.1.1 255.255.0.0
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 network 10.0.0.0
 network 172.16.0.0
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


Router#